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Introduction 
 
The KzComm Windows PC program supports the following functions for Kurz flow 
transmitters: 

 Configuration file loading and extraction (upload/download) 
 Configuration file conversion for human reading (printable file) 
 Extraction of internal log files:  min/max, event, and trend 
 Sensor data loading: flow calibration and temperature compensation parameters 
 Basic meter configuration changes, both online and offline 
 

KzComm is a computer program that uses XMODEM or MODBUS RTU protocols to 
communicate with the Kurz Instruments devices. These devices are limited to those that 
have the following firmware names: MFT, PTA and MFT-B. The MFT and PTA firmware 
uses the XMODEM communication protocol via RS-232C port and the MFT-B firmware 
uses the XMODEM communication protocol via USB port or MODBUS protocol via RS-
485 port or MODBUS TCP. The MFT-B firmware requires the Kurz USB Device Driver 
for the PC to be installed prior to using the USB port on the MFT-B electronics. 

 

Interconnection Requirements 
 
The models with MFT-B firmware, e.g. 504FTB, 454FTB, 534FTB, and KBAR2000B, 
need a two-wire shielded cable for Modbus RTU, a USB Type A to mini B cable for the 
XMODEM protocol, or an ethernet cable to a Modbus TCP to RS-485 gateway for the 
Modbus TCP protocol. The PC requires the Kurz USB Device Driver for the PC to be 
installed prior to connecting a USB cable to the MFT-B electronics. 
 
Models that have the MFT firmware, like the 504FT, 454FT, 534FT and KBAR-2000, 
need a cable with a DB-9 connector at both ends and 1 to 1 pin configuration of the 
communication cable. If the PC does not have the DB-9 COM port but has the DB-25, 
use an adapter (DB-25 to DB-9). The PC must have at least one RS-232C 
communication port. The communication cable can be purchased at the factory with the 
part number 260102. A USB to RS-232 “dongle” can also be used in some cases, but it 
depends on the device. 
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Models that have the PTA firmware, like the Series 2440, need a cable with a DB-9 
connector at both ends and 1 to 1 pin configuration of the communication cable. If the 
PC does not have the DB-9 COM port but has the DB-25, use an adapter (DB-25 to DB-
9). It is necessary that the I/O adapter board is available. The I/O adapter board can be 
purchased as an option for the Series 2440 models. The I/O adapter board part number 
is 260106. 
 
 
Using KzComm  
 
Running KzComm 
 
After installing the program, KzComm can be run by double clicking its icon on the 
desktop or clicking the Start button, All Programs, Kurz Instruments, and KzComm 
Version x.xx.  All program data is, by default, sent to the [Common App Data 
Folder]\KzComm.  This folder is located, by default, on Windows 2000 and XP, at 
C:\Documents and Settings\All Users\Application Data\Kurz Instruments\KzComm and 
Windows Vista and 7 at C:\Program Data\Kurz Instruments\KzComm. Kurz Instruments 
Models with MFT-B firmware devices using the USB port on the electronics require the 
Kurz USB Device Driver for the PC to be installed. 
 
KzComm Messages 
 
Upon a communications setup change, KzComm will attempt to display the sensor 
serial number and the tag name of the connected Kurz Instruments device.  See Device 
Identification for more information on the messages. 
 
Windows Vista Support 
 
Windows Vista is supported by KzComm.  A known issue exists when downloading the 
volatile trend log.  This issue is rare and causes the operating system to freeze. The 
symptoms include the display not updating when the mouse is moved or keys are 
pressed.  To correct the problem, restart the machine by pressing the manual power 
button on your computer.  Note that the manual power restart may require holding the 
power button for at least 5 seconds.  When the system recovers, continue as normal. 
 
Configuring the Communication Port 
 
Before any communication is initiated, make sure that the PC and the Kurz Instruments 
Device have the same communication parameters.  
 
Configure the communication port for KzComm as follows: 
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1. Click the Communication on the menu bar and click Configure on the popup 
menu. 

2. Choose the desired communications protocol by clicking on the radio button or 
section title. 

 

 
 

3. In the Modbus TCP section, enter the IP address of the Modbus TCP device and 
the Modbus address of the device with which to communicate.  

 

 
 

4. In the Modbus Serial RTU section, select the communications port of the Modbus 
device, baud rate, and Modbus address of the device with which to 
communicate.  See Step 5 on how to determine the COM port of the Modbus 
device. 
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5. In the XMODEM section, select the communication port of the PC that will be 
used on the Com Port list box.  Note that if a USB to RS-232 or USB To RS-485 
device is used then it will enumerate as a COM port.  To determine which COM 
port was assigned, if the enumerated name is not specific enough, open the 
device manager by clicking the Start Menu and then Run.  In the text field input 
devmgmt.msc and hit enter, as shown below. The Kurz Instruments Device 
which should be labeled as Kurz USB-HID -> COM device, if delivered prior to 
September 2011, or USB Serial Port, if delivered after that date.  If a USB to 
RS-485 device is used, its name may reference the manufacturer so to verify 
which port it is, unplug it, and plug it back in.  The COM port that disappears and 
reappears will be the port to be used.  See the USB Driver Installation Guide for 
device driver issues.  Note that the Kurz Instruments Devices with MFT-B 
firmware only support 9600 baud for the XMODEM protocol. 

 

 
 
When the Device Manager opens expand the Ports (COM & LPT) section by clicking 
on the + symbol or double clicking the section header. 
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6. In the KzComm Communications Setup window, select the baud rate that will be 
used in the Baud Rate list box.  

 

 
 
7. When the COM port and baud rate have been set, click the OK button on the 

Communications Setup window.  KzComm will then determine the sensor serial 
number and tag name of the device with which it has been configured to 
communicate.  Note this feature will only return valid information for Kurz 
Instruments Devices with MFT-B firmware 1.05 or later. 

 



KzComm User’s Guide 
DCN 280128 Rev. H – 08-19-2011 

8 

 
 
Device Identification 
 
Upon first loading the program the following will be displayed. 
 

 
 
After going to Communications -> Configure, selecting valid communication options 
and clicking OK, you should see the following: 
 

 
 
Then one of the following results will occur: 
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1. When connecting with Xmodem, a MFT B-Series device using firmware 1.05 or 
newer will display the normal startup identification. The device’s sensor serial 
number and tag name will be displayed as shown below. Uploading, 
downloading, and updating of the Flow Calibration Data can be performed. 
Downloading of the Min/Max, Event, and Trend logs are dependent on the 
version of the device’s firmware.  Note that the sensor serial number will be used 
as the default filename for downloading the configuration, Min/Max, Event, and 
Trend logs. Sometimes when connecting with Xmodem, the Configure may fail to 
read the Sensor Serial Number and Tag Name.  Try Reset Xmodem COM Port 
and then Configure again. 

 
2. When connecting with Modbus, a MFT B-Series device using firmware 1.00 or 

newer will display the normal startup identification. The device’s sensor serial 
number and tag name will be displayed as shown below. Uploading, 
downloading, and updating of the Flow Calibration Data can be performed. 
Downloading of the Min/Max, Event, and Trend logs are dependent on the 
version of the device’s firmware. Note that the sensor serial number will be used 
as the default filename for downloading the configuration, Min/Max, Event, and 
Trend logs. 

 

 
 

3. When connecting with Xmodem, a MFT B-Series device using firmware 1.04 or 
older will not display the normal startup identification. The following popup will be 
displayed. 

 

 
 
 Then the main window will be displayed as follows: 
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Uploading, downloading, and updating of the Flow Calibration Data can be 
performed.  Downloading of the Min/Max, Event, and Trend logs are dependent 
on the version of the devices firmware. 

 
4. When connecting to a MFT or PTA device using any firmware will not display the 

normal startup identification. The following popup will be displayed. 
 

 
 

Then the main window will be displayed as follows: 
 

 
 

Uploading, downloading, and updating of the Flow Calibration Data can be 
performed, but downloading of the Min/Max, Event, and Trend logs are not 
supported. 
 

5. For any invalid communications setup, the following popup will be displayed.  
Sometimes when connecting with Xmodem, the Configure may fail to read the 
Sensor Serial Number and Tag Name.  Try Reset Xmodem COM Port and then 
Configure again. 
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The main window will be displayed as follows: 
 

 
 

Uploading, downloading, and updating of the Flow Calibration Data cannot be 
performed until the communications are established. 

 
MFT B-Series to PC via USB Connection Problems 
 
Issue: When connecting via HyperTerminal, gibberish characters may be displayed. 
 

 
Terminal Emulator Displaying Gibberish 
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General Notes: Always disconnect from the terminal before disconnecting or powering 
down the MFT B-Series unit. 
 
KzComm:  See Reset XMODEM COM Port. 
 
Terminal Emulator: 

Solution 1: Use Tera Term Pro 4.70 or latest (Supports COM1 through COM15). 

1. Open Tera Term Pro. 
2. Connect  

a. Tera Term Pro only allows connections to COM1 through 15.  Use the 
Device Manager (type devmgmt.msc from the Start -> Run window) 
to change the COM port to a lower number.  

b. Only the COM port needs to be chosen.  
3. If gibberish is seen then select Control -> Reset port.  
4. Save the setup by selecting Setup -> Save Setup...  
5. Create a shortcut to Tera Term Pro on your desktop.  

Solution 2: Use Tera Term Pro 3.1.3 (Only supports COM1 through 4). 

See Solution 1, but only supports COM1 through 4. 

 Solution 3: Use HyperTerminal 

1. Setup HyperTerminal with the correct COM port, 9600 baud rate, 8 data bits, 
no parity, 1 stop bit, and no flow control.  

2. File -> Save As and save it to your desktop.  
3. Open the connection.  If gibberish disconnect and exit HyperTerminal and 

repeat until the 3rd failure.  
4. If gibberish, disconnect and close HyperTerminal.  Open the Device Manager 

(type devmgmt.msc from the Start -> Run window) to change the COM port 
baud rate to any other value not previously used and exit the COM properties 
window.  Disconnect the USB from the computer wait a few seconds and 
reconnect.  

5. Go to Step 3 and repeat until working.  
 
Downloading Configuration File 
 
KzComm supports downloading the configuration files from Kurz Instruments Models 
with MFT, PTA and MFT-B firmware. It is necessary to download and save the 
configuration file from a Kurz Instruments device for two reasons:  

1. To have a backup of how the unit was setup (that can be moved to different 
hardware). 
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2. The configuration file can be converted to text file so you can review how the unit 
was setup.  

To download the configuration file, perform the following: 

1. Click the File on the menu bar then click Download. 

2. Check the Configuration File checkbox and click OK as shown below. 

 

3. Enter or select the filename on the new popup window.  If the Communications 
-> Config option is used prior to downloading the configuration file, the sensor 
serial number will be shown as the default filename.  See Running KzComm for 
the default file locations. 

 

4. If an error occurred, click the OK button and repeat the above steps.  Note that 
the configuration file will be converted to viewable file with the same filename 
except that its extension will be “.txt”.  It will also be opened for viewing in the 
default text editor. 

 



KzComm User’s Guide 
DCN 280128 Rev. H – 08-19-2011 

14 

Downloading Min/Max and Event Log Files 
 
KzComm supports downloading the log files from Kurz Instruments Models with MFT-B 
1.05 firmware or later. The Min/Max log file contains 20 records for each of the following 
events: minimum flowrate, maximum flowrate, minimum process temperature, maximum 
process temperature, minimum electronics temperature, and maximum electronics 
temperature.  This log can be used to determine the range of the flowrate, temperature, 
and electronics temperature for the process being measured by the Kurz Instruments 
MFT B-Series Device.  The Event log file contains up to 260 of the most recent events 
determined and reported by the Kurz Instruments MFT B-Series Device.  The log files 
are saved in Comma Separated Variable format (*.csv) that is easily imported into any 
spreadsheet program. 
 
To download the Min/Max and Event log files, perform the following: 
 

1. Click the File on the menu bar then click Download. 
2. Check the Min/Max and Event Log Files checkbox and click OK as shown below. 
 

 
 

3. Enter or select the filename of the Min/Max Event log on the new popup window.  
If the Communications -> Config option is used prior to downloading the log 
files, the sensor serial number will be shown as the default filename with 
_minmax appended.  See Running KzComm for the default file locations. 
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4. Enter or select the filename of the Event log on the new popup window.  If the 
Communications -> Config option is used prior to downloading the log files, the 
sensor serial number will be shown as the default filename with _event 
appended.  See Running KzComm for the default file locations. 

 

 
 

5. If an error occurred, click the OK button, verify that the MFT-B is not in boot-up 
mode, and repeat the above steps.  Note that the log files will be opened for 
viewing by the program defaulted to the .csv extension.  If Microsoft Excel or 
OpenOffice Calc is installed it will open in the installed program.  Windows’ 
default program for .csv files is WordPad. 
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Downloading Volatile Trend Log File 
 
KzComm supports downloading the log files from Kurz Instruments Models with MFT-B 
1.05 firmware or later. The Volatile Trend log file contains 20416 records.  Each record 
contains the runtime, flowrate, and process temperature and they are taken every 10 
seconds with the oldest record being replaced by the newest when all of the records 
have been used.  This log contains approximately 2 ½ days worth of data. This log can 
be used to determine how the process being measured by the Kurz Instruments MFT B-
Series Device changes with time and if an unusual event occurs this log may contain 
more detailed data on what happened with the process.  Note that this log is in volatile 
memory and therefore a power cycle will clear the trend log.  The log files are saved in 
Comma Separated Variable format (*.csv) that is easily imported into any spreadsheet 
program.  See the Windows Vista Support section for known issues. The downloading 
of the Volatile Trend Log will take 4 minutes using Modbus RTU at 38400 baud and 17 
minutes using the Xmodem protocol. 
 
To download the trend log file, perform the following: 
 

1. Click the File on the menu bar then click Download. 
2. Check the Volatile Trend Log checkbox and click OK as shown below.  Note that 

the estimated time for the log file download is displayed. 
 

 
 

3. Enter or select the filename of the trend log on the new popup window. If the 
Communications -> Config option is used prior to downloading the log file, the 
sensor serial number will be shown as the default filename with _trend 
appended.  See Running KzComm for the default file locations. 
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4. If an error occurred, click the OK button, verify that the MFT-B is not in boot-up 
mode, and repeat the above steps.  Note that the log files will be opened for 
viewing by the program defaulted to the .csv extension.  If Microsoft Excel or 
OpenOffice Calc is installed it will open in the installed program.  Windows’ 
default program for .csv files is WordPad. 
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5. A graph of the trend log will be displayed as shown below.  To save the graph as 
a JPG image and exit click the Save Image button, otherwise click the Exit 
button to exit the Volatile Trend Graph.  The image of the graph will have the 
same filename as the log file with the exception of the extension being jpg. 

 

 
 
MFT B-Series Boot-up Mode 
 
The MFT-B performs power on test to verify that the configuration, sensor, and wiring 
are valid.  While it is testing, the following display screens can be seen on unit with 
displays or via a terminal emulator program. 
 

KURZ INSTRUMENTS  
 
DISPLAY DRIVER 4.1  

 
The above display is the version information of the display itself and will not be seen 
when using a terminal emulator program. 
 

CHECKING TYPE OF  
 
CONNECTED SENSOR  

 
The sensor testing is in progress.  If the next display is an error message display then 
the unit is stuck in boot-up due to a sensor mismatch, wiring or other problem. At this 
point the MFT-B will not allow downloading of the Min/Max, Event or Trend logs.  To 
force the unit to exit boot-up mode the user must press the 'c' key on the display or via a 
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terminal emulator program.  Once boot-up is complete the following screen will be 
displayed. 
 

KURZ INSTRUMENTS  
 
SERIES MFT-B 

 
Followed within seconds by the final sensor test, downloading of the Min/Max, Event or 
Trend logs can now be accomplished. 
 

 

 
The Run Mode screen will be displayed. 
 
Uploading Configuration File 
 
Kurz Instruments Models with MFT, PTA and MFT-B firmware are supported to upload 
their configuration file from a PC. 
 
To upload a configuration file, perform the following: 
 

1. Click File on the menu bar then Upload (PC to Target). 
2. Enter or select the filename on the new popup window.  See Running KzComm 

for the default file locations. 
 

 

WAIT PERFORMING  
 
SENSOR LEAK TEST  
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3. If an error occurred, click the OK button and repeat it the above operations.  
 

Converting Configuration File from Binary to Text 
 
Configuration files are in a binary format. In order to read or print they need to be 
converted first to a text format. 
 
To convert a binary configuration to a text format, perform the following: 
 

1. Click the File on the menu bar then click Create Printable File. 
2. Enter or select the binary configuration file name in the new popup window.  See 

Running KzComm for the default file locations.  
 

 
 

3. Enter or Select the Text configuration file name on the new popup window. 
 



KzComm User’s Guide 
DCN 280128 Rev. H – 08-19-2011 

22 

 
 

See Viewing the Configuration File on how to view the configuration file. 
 
Viewing the Configuration File 
 
Any text editor or word processor can be used to view the text version of the 
configuration file because it is in plain text. This program uses the operating system’s 
associated program, based on file type, to view the file. Therefore, do not use a file 
extension, when Converting Configuration File from Binary to Text, not supported by a 
default text editor unless the user is knowledgeable enough to change the custom file 
type to be opened by a text editor. 
 
To view the text version of the configuration file, perform the following: 
 

1. Click File on the menu bar then View. The View option is disabled until the 
Create Printable File is performed. 

2. The default text editor will open and load the text version of the configuration file. 
Close the program when finished.  

 
Printing the Configuration file 
 
Any text editor or word processor can be used to view the text version of the 
configuration file because it is in plain text. This program uses the operating systems 
associated program, based on file type, to print the file. Therefore, do not use a file 
extension, when Converting Configuration File from Binary to Text, not supported by a 
default text editor unless the user is knowledgeable enough to change the custom file 
type to be opened by a text editor. 
 
To print the configuration file, perform the following: 
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1. Click the File on the menu bar then click Print. The Print option is disabled until 
the Create Printable File is performed. 

2. The file will be sent to the default printer.  To print to a different printer, see 
Viewing the Configuration File and print from the program in which it opens.  

 
Updating the Flow Calibration Data 
 
The flow calibration data can be loaded into the Kurz Instruments Models with MFT, 
PTA, and MFT-B firmware using the update flow calibration data functionality. This 
option is used to update the flow calibration of the meter to support changing gas types, 
Velocity Temperature Mapping (VTM) data, or switching between multiple calibration 
curves. 
 
To update the flow calibration data, perform the following: 
 

1. Click Update on the menu bar then Flow Calibration Data. 
2. Enter or select the filename of the flow calibration file.  See Running KzComm for 

the default file locations. 
 

 
 

3. If error occurred, click the OK button and repeat the above steps. 
 

Updating the Sensor Data 
 
Kurz Instruments Models with MFT-B firmware can have their sensor data loaded by 
using the update sensor data function. This option is used to update sensor specific 
Resistance Temperature Device (RTD) calibration coefficients. 
 
To update the temperature compensation data, perform the following: 
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1. Click Update on the menu bar then Sensor Data. 
2. Enter or select the filename of the temperature compensation data file.  See 

Running KzComm for the default file locations. 
 

 
 

3. If an error occurred, click the OK button and repeat the above steps. 
 
B-Series Setup Wizard 
 
The Wizard is used to configure a MFT-B device with 2.00 or newer firmware only.  The 
wizard will not work with a MFT\PTA device or a MFT-B device with 1.XX firmware.  It 
will prompt the user with an error message stating that the “User Selected File is 
Invalid!”.  
 
First choose whether you are currently connected to the MFT-B device (Online) or 
whether the configuration file to be used is already on your PC (Offline). 
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Online 
 
If Online is selected, the Communications Setup window will prompt the user for 
a connection type. 
 

 
 
Until the connection has been established, the Next button on the Connection 
Type window will be disabled. 
 
Offline 
 
If Offline is selected, the Wizard will prompt for a configuration file. 
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The sensor serial number, tag name, modbus address and gas of the device to be 
configured are displayed for verification purposes.  Next choose the mode of 
configuration.  The two options are as follows: 
 

 
 

1.  Initial Setup for First Time Use 
 
Used for initial commissioning.  Some assumptions and defaults are used for 
initial numbers that can be overwritten by the user. 
 

2. Reconfiguration via Basic PC Setup 
 

Used to make individual setup changes once configured or for the more 
advanced user. 
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Follow the links to Initial Setup for First Time Use or Reconfiguration via Basic PC Setup 
for more information. 
 

Initial Setup for First Time Use 
 
The user is queried for what measurement is required.  This choice will limit the 
units and options available for choice in later steps. 
 

 
 

Flow Meter Commissioning 
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The Area Wizard simplifies the entry of the Area, by allowing the circular 
dimensions, rectangular dimensions, or NPS pipe sizes to be entered. 

 

 
 

The Insertion Diagram shows how to measure the Probe Insertion Depth. 
 

 
 

Analog Outputs Commissioning 
 
The Analog Output 1 Type is defined by the Measurement Mode Step. 
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Modbus 
 

 
 

Summary 
 
All changes are highlighted in yellow and when the cursor is hovering over 
a changed field, a pop up text will display the original value.  The Finish 
button will be disabled if no changed have been made. 
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If the Wizard is in Online Mode, then the user is prompted to save the 
configuration file and/or upload the changed configuration to the attached MFT-B 
device. 
 

 
 
Otherwise the user is prompted to save the configuration file.  Note that the tag 
name, date, and time are used as a default that can be overwritten by the user. 
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Reconfiguration via Basic PC Setup 
 

Flow Meter 
 

 
 

The Area Wizard simplifies the entry of the Area, by allowing the circular 
dimensions, rectangular dimensions, or NPS pipe sizes to be entered. 

 

 
 

The Insertion Diagram shows how to measure the Probe Insertion Depth. 
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Analog Outputs 
 

 
 

Modbus 
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Summary 
 
All changes are highlighted in yellow and when the cursor is hovering over 
a changed field, a pop up text will display the original value.  The Finish 
button will be disabled if no changes have been made. 

 

 
 
If the Wizard is in Online Mode then the user is prompted to save the 
configuration file and/or upload the changed configuration to the attached MFT-B 
device. 
 

 
 
Otherwise the user is prompted to save the configuration file.  Note that the tag 
name, date, and time are used as a default that can be overwritten by the user. 
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Program Menus 
 
The KzComm program is shown below.  The menu options are File, Update, 
Communications, and Help. 
 

 
 
File Menu Options 
 
The File Menu options are shown below. The options are Download, Upload, Create 
Printable File, View, Print, and Exit. 
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File -> Download (Target to PC) 
 

Click the File, then Download (Target to PC) to download the configuration file, 
Min/Max, Event, or Trend logs from the Kurz Instruments Devices with MFT, PTA 
or MFT-B firmware to the PC.  
 

Note 1: Kurz Instruments Devices with MFT or PTA firmware, or MFT-B 
firmware 1.04 or earlier do not support the Min/Max, Event or Trend log 
files.  
Note 2: The Min/Max, Event and Trend log files cannot be downloaded 
while the MFT-B is in boot-up. 
 

The act of downloading of a file will automatically open the file with the default 
editor/viewer for that given file type.  All log files are in Comma Separated 
Variable (*.csv) format and the configuration file in viewable format is in Text 
(*.txt) format. 
 
See Downloading the Configuration File, Downloading the Min/Max and Event 
Logs, and Downloading the Volatile Trend Log for more information. 

 
File -> Upload (PC to Target) 

 
Click File then Upload (PC to Target) to upload the configuration file of the Kurz 
Instruments device with MFT, PTA or MFT-B firmware from the PC. 
 
See Uploading the Configuration File for more information. 
 
File -> Create Printable File 

 
Click the File then Create Printable File to convert the binary configuration file 
to a human readable text file. 
 
See Converting Configuration File from Binary to Text for more information. 
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File -> View 
 

Click the File then click View to view the text version of the configuration file. 
 
See Viewing the Configuration File for more information. 
 
File -> Print 

 
Click File then Print to print a hard copy of the text version of the configuration 
file to the default printer. 
 
See Print the Configuration File for more information. 

 
File -> Exit 

 
Click the File then Exit to terminate the program. 

 
Update Menu Options 
 
The Update Menu options are shown below. The options are Flow Calibration Data and 
Sensor Data. 
 

 
 

Update -> Flow Calibration Data 
 

Click Update then Flow Calibration Data to update the calibration data of the 
Kurz Instruments device with MFT, PTA or MFT-B firmware with a valid 
calibration file.  
 
This menu permits you to load in calibration files for different gases (one at a 
time) or change VTM data etc. 
 
See Updating the Flow Calibration Data for more information. 
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Update -> Sensor Data 
 

Click Update then Sensor Data to update the Kurz Instruments Models with 
MFT-B firmware with a valid sensor file. 
 
See Updating the Sensor Data for more information. 
 

Communications Menu Options 
 
The Communications Menu options are shown below. The options are Configuring the 
Communications Port and Reset Xmodem COM Port. 
 

 
 

Communication -> Configure 
 

Click Communication then Configure to setup the communication port, 
protocol, and Modbus address to be used. 
 
See Configuring the Communications Port for more information. 
 
Communication -> Reset Xmodem COM Port 
 
Click Communication then Reset Xmodem COM Port to reset the XMODEM 
communication port.   

 
This feature will be disabled if the chosen communications protocol is not 
XMODEM.  This option should be used when a terminal emulator program is 
receiving garbage characters on its display or when KzComm is unable to 
communicate to the MFT B-Series unit using the XMODEM protocol and the 
setup and connections have been proven to be valid.  This feature will reset the 
communications port in a manner that will correct the communications problems 
with the PC and its COM port.   
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Usage 1: Terminal Emulator displaying garbage and the emulator does not 
provide the Reset Port option.  Note Tera Term provides this option and is the 
recommended terminal emulator. 
 

1. Disconnect or close the terminal emulator program from the COM 
port.  

2. Open KzComm if not already open.  
3. Choose Communication -> Reset Xmodem COM Port.  If the 

option is disabled change the configuration to the XMODEM 
protocol.  

4. Open or connect the terminal emulator program and it should now 
display valid data.  

 
Usage 2: KzComm throws warning or displays communications invalid with valid 
setup to MFT-B unit.   
 

1. Verify connection between PC and MFT-B with proper USB cable, 
COM port enumerated, power supplied to unit and communications 
configuration are valid.  

2. Choose Communication -> Reset Xmodem COM Port.  If the 
option is disabled change the configuration to the XMODEM 
protocol.  

3. Try the previously requested command again.  
 
Wizard Menu Options 
 
The Wizard Menu options are shown below.  The only option is B-Series Setup. 
 

 
 

Wizard -> B-Series Setup 
 

See B-Series Setup for how to use the wizard. 
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Help Menu Options 
 
The Help Menu options are shown below. The options are Help Topics and About 
KzComm. 
 

 
 

Help -> Help Topics 
 

Click Help then Help Topics to learn more about the program. 
 

Help -> About KzComm 
 

Click Help then About KzComm to know the version of the program 
 




